Starter Master Pages Update v1.3 7

Over the weekend I pushed out a small but important update to my starter master pages. When I originally created the starter master pages I used both the Design Manager feature as well as Seattle and Oslo to decide the best place to put things in the master page. There was a discrepancy between where the Design Manager and the default master pages placed the SPWebPartManager control. Turns out the Design Manager puts this control in the <head> section which is incorrect, it should be in the <body>. Having the control load before the <body> caused a host of mysterious problems so I have moved it to the body and I urge everyone to follow suit.

Starter Master Pages for SharePoint 2013 v1.3

UPDATE: 2010 Starter Master Pages can be found here: http://startermasterpages.codeplex.com/releases/view/41533

7 thoughts on “Starter Master Pages Update v1.3

  1. Reply Bruce Bentley Apr 24,2013 5:01 pm

    What were some of the mysterious things that you noticed if you don’t mind me asking.

    Thanks!

    • Reply Randy Drisgill Apr 24,2013 5:57 pm

      I received a bunch of reports from people, I can’t recall them now but personally I saw videos without the play button and a strange issue with search center branding erroring. Both started working after changing this back.

      • Reply Bruce Bentley Apr 25,2013 9:46 am

        No worries. Just figured I’d ask!

        Side Note: I appreciate all the hard work and dedication you put in to these for a side project. Saved us all all COUNTLESS hours in the dev environments.

  2. Reply Matt May 22,2013 1:22 am

    I think I found an issue with the Oslo theme – not sure if it’s one you noted but it’s a doosey.

    I haven’t been able to have the ‘Add An App’ page load successfully using the Oslo theme in 2 different SP2013 environments. Works fine with Seattle theme. Almost seems to be related to DOM loading because when I debug and step over everything, it works! Otherwise I just get this error ‘SCRIPT5007: Unable to get value of the property ‘className’: object is null or undefined’.

    Haven’t seen it referenced elsewhere online but thought I’d mention it here. I think it’s related…

  3. Reply Robert Sep 28,2013 3:13 pm

    Hi Randy;
    I clicked on a link for the SP 2010 Starter Master and arrived here. Seems like every link to the 2010 Starter Master comes here. Can Starter Master Pages for SharePoint 2013 v1.3 be used for SP 2010? If not, is the 2010 Starter Master still available?

    Thanks,
    Robert

Leave a Reply